応用情報 科目A 17:IPv4サブネット,CIDR,ルーティング判断

応用情報技術者試験の科目Aに必要なIPv4のサブネットマスクとAND演算、ネットワーク・ブロードキャストアドレス、均等分割、CIDR集約、最長一致ルーティング、/31・/32とプライベートアドレスを、計算例題とオリジナル演習問題5問で学びます。

応用情報技術者試験科目AネットワークIPv4サブネットCIDR

AP科目A・第17回 · 2026年度・シラバスVer.7.2に基づく独立した学習資料です。IPAとの提携はなく、合格を保証しません。 シリーズ一覧を見る

2026年試験基準・改訂/出典確認 2026-10-21・主言語:韓国語

学習インデックス

  1. 公式範囲と用語 2. 計算手順 3. アドレス範囲 4. 等分割 5. 集約とルーティング 6. 例外とアドレス範囲 7. 問題 8. 復習

1. 公式範囲と用語

IPA Ver.7.2の大分類3 技術要素 > 中分類10 ネットワークのうち,1. ネットワーク方式 > (7) インターネット技術及び3. 通信プロトコル > (1) プロトコルとインタフェース > ③ ネットワーク層のプロトコルに対応する。掲載位置はPDF 47~49ページ/印刷フッター43~45ページである。AP1の2進数計算はANDとの接続だけにとどめ,再解説しない。AP16の階層では,IPアドレスとルーティングはネットワーク層の役割である。

KO JA EN 意味
접두 길이 プレフィックス長 prefix length 先頭のネットワークビット数
서브넷 마스크 サブネットマスク subnet mask ネットワーク部が1,ホスト部が0
네트워크 주소 ネットワークアドレス network address 通常はホスト部が全て0
지향성 브로드캐스트 ディレクテッドブロードキャスト directed broadcast 通常はホスト部が全て1
사용 가능 호스트 범위 利用可能ホスト範囲 usable host range 通常はネットワークとブロードキャストの間
경로 집약 経路集約 route aggregation 連続するプレフィックスを過不足なく一つで表す
최장 접두 일치 最長プレフィックス一致 longest-prefix match 一致する中で最長の経路を選ぶ

/26は先頭26ビットがネットワーク部で,マスクは255.255.255.192である。アドレスとマスクのビット単位ANDでネットワークアドレスを得る。

2. コンパクトな計算手順

  1. /pをマスクに直し,ホストビット数h=32-pを求める。
  2. IPとマスクのANDでネットワークアドレスを求める。
  3. ホストビットを全て1にしてブロードキャストを求める。
  4. 通常のマルチアクセスサブネットなら,その間が通常利用可能で個数は2^h-2。
  5. 等分割では2^b ≥ 必要サブネット数となる最小のビット数を借り,新プレフィックスをp+bとする。
  6. ルーティングでは全ての一致のうち最長プレフィックスを選ぶ。行順ではない。

3. アドレス範囲:192.168.10.77/26

  • マスク:255.255.255.192
  • 最終オクテット:77 = 01001101,192 = 11000000
  • AND:01001101 AND 11000000 = 01000000(=64)
  • ネットワーク:192.168.10.64
  • ブロードキャスト:192.168.10.127
  • 通常利用可能:192.168.10.65–192.168.10.126
  • 通常利用可能ホスト:2^(32-26)-2 = 62

4. 等分割:10.20.30.0/24を6個以上に

2^2=4では不足し,2^3=8なので3ビット借りて/27にする。各ブロックは32アドレス,通常利用可能ホストは30である。

番号 ネットワーク ブロードキャスト 通常利用可能範囲 全体/通常
1 10.20.30.0/27 10.20.30.31 10.20.30.1–10.20.30.30 32/30
2 10.20.30.32/27 10.20.30.63 10.20.30.33–10.20.30.62 32/30
3 10.20.30.64/27 10.20.30.95 10.20.30.65–10.20.30.94 32/30
4 10.20.30.96/27 10.20.30.127 10.20.30.97–10.20.30.126 32/30
5 10.20.30.128/27 10.20.30.159 10.20.30.129–10.20.30.158 32/30
6 10.20.30.160/27 10.20.30.191 10.20.30.161–10.20.30.190 32/30
7 10.20.30.192/27 10.20.30.223 10.20.30.193–10.20.30.222 32/30
8 10.20.30.224/27 10.20.30.255 10.20.30.225–10.20.30.254 32/30

5. 正確な集約と最長プレフィックス一致

10.0.8.0/24と10.0.9.0/24は連続し,/23境界に整列しているので,過不足なく10.0.8.0/23に集約できる。一方,10.0.8.0/24と10.0.10.0/24を覆う最小の単一プレフィックスは10.0.8.0/22だが,10.0.9.0/24と10.0.11.0/24も含むため,正確な集約ではない。

プレフィックス 経路
10.0.0.0/8 A
10.20.0.0/16 B
10.20.30.0/24 C
10.20.30.128/25 D
0.0.0.0/0 E

結果は10.20.30.200 → D,10.20.30.100 → C,10.20.99.1 → B,10.99.1.1 → A,8.8.8.8 → Eである。表の行順ではなく,一致ビット数が最も多い経路を選ぶ。

6. 例外,アドレス範囲,試験の落とし穴

2^(32-p)-2は,ネットワークアドレス一つとディレクテッドブロードキャスト一つを予約する通常のマルチアクセスサブネットにだけ適用する。RFC 3021のポイントツーポイント/31は両アドレスを端点として使う。/32は一つのアドレス又はホスト経路を示す。式を機械的に当てはめて0や-1としてはならない。

プライベートブロックは正確に10.0.0.0/8,172.16.0.0/12,192.168.0.0/16である。プライベートアドレスとNATは同義ではない。 前者はアドレスのスコープ,後者はアドレス/ポート対応を書き換える機能である。プライベートでないことはグローバルにルーティング可能であることを自動的に意味しない。IANAには特殊用途範囲もある。NAT自体はセキュリティ保証ではない。

  • /27の増分は27ではなく32。所属は10進表記の見た目でなくANDで判断する。
  • 同じ大きさでも,連続性と境界整列がなければ正確に集約できない。
  • デフォルト経路/0は,より具体的な一致がない場合にだけ選ばれる。

7. オリジナル問題5問

Q1

172.16.35.200/27の範囲として正しいものはどれか。 ア ネットワーク.192,ブロードキャスト.255,利用.193–.254 イ ネットワーク.200,ブロードキャスト.231,利用.201–.230 ウ ネットワーク.192,ブロードキャスト.223,利用.193–.222 エ ネットワーク.224,ブロードキャスト.255,利用.225–.254

正解:ウ(3)。 アは/26のように広げている。イはホストアドレスを境界と誤認している。ウが192~223ブロックの正しい範囲。エは次の/27ブロックである。

Q2

192.168.50.0/24を5個以上の同サイズサブネットにする最小分割はどれか。 ア /26,4個,各通常62 イ /27,8個,各通常30 ウ /28,16個,各通常32 エ /29,5個,各通常6

正解:イ(2)。 アは4個で不足。イは3ビット借りて8個,各32アドレス/通常30。ウの通常利用可能数は14で,最小分割でもない。エは5個でなく32個できる。

Q3

10.4.8.0/24と10.4.9.0/24の正確な集約はどれか。 ア 10.4.8.0/24 イ 10.4.8.0/22 ウ 10.4.9.0/23 エ 10.4.8.0/23

正解:エ(4)。 アは二つ目を含まない。イは不要な二つの/24も含む。ウは/23の偶数境界に整列しない。エだけが連続する二つの/24を過不足なく含む。

Q4

上のルーティング表で宛先10.20.30.140に使う経路はどれか。 ア /25 → D イ /24 → C ウ /16 → B エ /0 → E

正解:ア(1)。 アは.128–.255の/25に一致し最長。イとウも一致するが具体性が低い。エは最も具体性の低いデフォルトである。

Q5

アドレス数の説明として正しいものはどれか。 ア /26は通常64ホスト,/31は0 イ /26は62,/31は0,/32は0 ウ /26は通常62,RFC 3021のポイントツーポイント/31は2端点,/32は1アドレス エ /26は通常63,/31は1端点,/32は2アドレス

正解:ウ(3)。 アは全アドレス数と通常利用可能数を混同。イは/31と/32の意味を無視。ウは通常式の条件と例外の両方が正しい。エは三つとも誤り。

解答キー:[3, 2, 4, 1, 3] = [ウ, イ, エ, ア, ウ]

8. クイックシート,セルフチェック,復習

  • クイックシート:network = IP AND mask,通常のbroadcast = host bits all 1,ブロックサイズ2^(8-対象オクテットのprefix bits),経路はlongest match。
  • セルフチェック:/26のマスクと64刻みの境界を書けるか。八つの/27を再現できるか。正確なaggregateと単なるcoverを区別できるか。/31,/32,private,NATの条件を説明できるか。
  • 1日後:マスク・AND・範囲の手順を見ずに再現する。
  • 3日後:/27表と五つのルーティング結果を白紙に書く。
  • 7日後:問題を再度解き,各誤答の理由まで説明する。

公式出典と告知

全て一次公式資料,2026-10-21確認:IPA syllabus Ver.7.2,RFC 4632 CIDR,RFC 1812 longest match,RFC 3021 /31,RFC 1918 private addresses,RFC 3022 Traditional NAT,IANA IPv4 Special-Purpose Address Registry。

本資料は独自制作の学習資料であり,IPA,IETF又はIANAとは提携していない。過去問題及び第三者解説は使用しておらず,試験合格を保証しない。

ブログへ